<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <div class="moz-cite-prefix">Bonsoir,</div>
    <div class="moz-cite-prefix"><br>
    </div>
    <div class="moz-cite-prefix">Le 10/11/2020 à 15:52, David Ponzone a
      écrit :<br>
    </div>
    <blockquote type="cite"
      cite="mid:5F7D6D00-CBCF-462A-8A64-337256C5FA54@gmail.com">
      <blockquote type="cite">
        <blockquote type="cite">
          <pre class="moz-quote-pre" wrap="">Hmm dans la conf de la PERC tu dois avoir un truc qui s’appelle read-ahead.
Vérifie que c’est bien activé sur les 2.
</pre>
        </blockquote>
        <pre class="moz-quote-pre" wrap="">
megacli dit : activé sur l'ancien cluster (mode adaptative pour être précis), désactivé sur le nouveau cluster. C'est grave, docteur ?

</pre>
      </blockquote>
      <pre class="moz-quote-pre" wrap="">
Difficile d’être sûr mais en tout cas c’est une différence:
Ancien cluster avec 2Go de cache et read-ahead
Nouveau cluster avec carte PERC la plus pourrie du marché, pas de cache, donc pas de read-ahead.

Mais ceci dit, regarder sur Google, la H330 est une grosse grosse bouze, comme Dell sait en mettre de temps en temps sur des serveurs de milieu de gamme (au hasard, R3XX ou R4XX ?).</pre>
    </blockquote>
    <br>
    Si c'est la carte avec un iostat, on doit voir le disque qui sature:<br>
    <br>
    Dans l'exemple ci-dessous, on voit sdb à 60% d'utilisation avec 30
    Mo/s en écriture et 176 Mo/s en lecture sur un vieux serveur Dell de
    2010:<br>
    <br>
    <font face="monospace"># iostat -xm 10<br>
      Device            r/s     w/s     rMB/s     wMB/s   rrqm/s  
      wrqm/s  %rrqm  %wrqm r_await w_await aqu-sz rareq-sz wareq-sz 
      svctm  %util<br>
      sdb            121.30  750.20     29.48    176.24     0.10    
      0.00   0.08   0.00    6.52    8.55   5.44   248.88   240.56  
      0.69  59.92<br>
      sda              0.60    9.80      0.07      0.11     0.00    
      7.00   0.00  41.67    6.17    3.05   0.02   128.00    11.59  
      1.96   2.04<br>
    </font><br>
    <p>Et si le problème n'est pas au niveau disque mais sur le NFS, il
      peut-être intéressant de changer la carte réseau et surtout le
      câble réseau utilisé (fibre, twinax, cuivre ?) sur le nouveau
      serveur.<br>
    </p>
    <p>Ceci étant pour les performances, le passage de LVM à Ceph
      améliore bien les chose.<br>
      Depuis le passage sur Ceph avec Proxmox 6, et malgré une vieille
      carte PERC6 RAID + de très vieux disques SAS, les débits réels
      Ceph sont très sympas : entre 300 et 400 Mo/s en écriture.<br>
      Et je ne parle même pas de la résistance aux pannes ;-)<br>
      <br>
      Bon courage.<br>
      -- <br>
    </p>
    <div class="moz-signature">
      <div style="color: rgb(0, 0, 0);font-family: Helvetica; font-size:
        12px;"><b>Emmanuel DECAEN</b><br>
        <br>
      </div>
    </div>
  </body>
</html>